Friday, 21 January 2022 18:53

Question: HSTS Security Enforcement, do I need it?

Written by

Many common vulnerability scans are now requiring and recommending HSTS security enforcement.  How easy is it to fix?

Answer:

Assuming your site already has an SSL certificate installed and working, this is a pretty simple fix. 

If you have CloudFlare, simply log into your Dashboard, browse to SSL/TLS -> Edge Certificates:

hsts cloudflare 

Last modified on Friday, 21 January 2022 19:02

Latest Comments

Nate Covington posted a comment in Download XMap for Joomla - All Versions Joomla
Hi, I stopped using Xmap years ago. Not sure about your particular error with Hikashop. I suggest ...
Jonathan Brain posted a comment in Download XMap for Joomla - All Versions Joomla
Got these errors with your copy of XMap for Joomla 3.0.x download when upgrading a Joomla / Hikashop...
Nate Covington posted a comment in Simple Drupal Webform (v4) PayPal Integration
@giucas - No, this is a "PayPal" thing. Most likely there IS a way for a user to pay with a guest a...
Joy Lewis posted a comment in Beware of Fraud: Web Design Scam
I had the same issue today, I'm glad I didn't respond it seemed really fishy. Thanks for getting i...
Thanks for this code! The paypal form doesn't allow guest payment (with credit card) but only via pa...

Web Design & Development

Wordpress, Drupal, Joomla
New custom websites
Bespoke themes and extensions
Redesigns, upgrades, migrations

Web Design & Development

Optimization & SEO

Let us optimize and manage your overall online presence. We offer full service monthly SEO as well as one-time projects.  

Optimization Plans & Pricing

Maintenance, Patching

White glove monthly backups, security updates, maintenance and testing for your Wordpress, Drupal, or Joomla site.

Maintenance Plans & Pricing

Stay in Touch!

Bring your web & marketing performance to the next level: monthly blog post roundup via email.  

Try it out