Displaying items by tag: Update

I've run into a few clients who have told me that other developers forced them into upgrading their Joomla installation (e.g. from Joomla 1.0 to 1.5, or 1.5 to 1.6).  I am hoping that this article will provide clarification and possibly save a few folks from going through this unnecessarily.

[Edit May 4, 2012]

  • You do not need to upgrade to Joomla 1.7
  • You do not need to upgrade to Joomla 2.5
  • You do not need to upgrade to Joomla 3.x 
  • Note: Upgrading is still a good idea!
Published in Blog